Subject: RE: TTL=255 on xmit, no check on receipt please

From: "Christian Huitema" <[email-masked]>
Date: Fri, 27 Dec 2002 09:17:29 -0800

>> And you should use IPv6 anyhow.
>
> Yes, but we can't wait 7 years for this to be ubiquitous enough...some of
> use need to get work done *now* as well.

There is absolutely zero barrier to deployment of IPv6 in a zeroconf scenario. We are speaking of communication between 2 computers on the same link, so the only requirement is agreement between these two computers on which software to use. The 7 years argument is plain bogus: we can make it work right now. 
 
Using IPv6 does require a software upgrade on those computers that don't have an IPv6 stack, but deploying a new IPv4 feature like auto-IP on those computers that don't support it yet also requires a software upgrade. Different parties may argue that one is easier or more productive than the other, and different parties will in fact argue different side of this argument. The truth is that we are speaking about shades of gray.
 
The other strong argument is that using IPv6 link local is a better solution than what zeroconf attempts to do with the IPv4 hack: at least, you get addresses that are for all practical purposes globally unique, and thus are not affected by events such as link split or intermittent connectivity.
 
-- Christian Huitema

---

From: "John C. Welch" <[email-masked]>
Date: Fri, 27 Dec 2002 14:31:25 -0500

On 12/27/2002 12:17, "Christian Huitema" <[email-masked]>
wrote:

> There is absolutely zero barrier to deployment of IPv6 in a zeroconf scenario.
> We are speaking of communication between 2 computers on the same link, so the
> only requirement is agreement between these two computers on which software to
> use. The 7 years argument is plain bogus: we can make it work right now.

Since you insist on dragging IPv6 into an IPv5 argument, name right now, all
shipping printer models with full IPv6 implementations, all applications
that can use IPv6 addressing and features.

>  
> Using IPv6 does require a software upgrade on those computers that don't have
> an IPv6 stack, but deploying a new IPv4 feature like auto-IP on those
> computers that don't support it yet also requires a software upgrade.
> Different parties may argue that one is easier or more productive than the
> other, and different parties will in fact argue different side of this
> argument. The truth is that we are speaking about shades of gray.

No, we are speaking about two different protocols. IPv6 support in the OS is
NOT the same as IPv6 being ubiquitous across a network, and we all know
this. OS X has full IPv6 support, but that's about it. Oh joy, how useful.

>  
> The other strong argument is that using IPv6 link local is a better solution
> than what zeroconf attempts to do with the IPv4 hack: at least, you get
> addresses that are for all practical purposes globally unique, and thus are
> not affected by events such as link split or intermittent connectivity.

IPv6 addressing has nothing to do with this. This entire argument is about
making IPv4 easier to use *now*, not in the magical future when IPv6 has
finally taken over. Can we attempt to stay on topic?

john

-- 
John C. Welch
Consultant III
Administrative Computing
(617) 253 - 1368 work
(508) 579 - 7380 cell
bynkii2          AIM