Subject: WG ACTION: 1 week to discuss [LL40] IPv4 LL does not alter the behavior of the DHCPv4 state machine

From: Erik Guttman <[email-masked]>
Date: Mon, 15 Dec 2003 14:08:37 +0100

Please send your comments to the working group mailing list.  Unless
there is an objection due to lack of time to work on this before the
holidays, the discussion will conclude on December 23.

Please see: http://www.merit.edu/mail.archives/zeroconf/msg00004.html
And: http://www.drizzle.org/~aboba/ZEROCONF/ll40.html

Erik

---

From: "Philip Nye" <[email-masked]>
Date: Tue, 16 Dec 2003 10:52:11 -0000

I am happy with the point but feel the proposed text is unwieldy.

How about:

"2.12 Interaction between DHCPv4 client and IPv4ll state machines

A device that implements both IPv4ll and a DHCPv4 client should not alter the behavior of the DHCPv4 client to accommodate IPv4 Link-Local configuration. In particular configuration of an IPv4 Link-Local address, whether or not a DHCP server is currently responding, is not sufficient reason to unconfigure a valid DHCP lease, to stop the DHCP client from attempting to acquire a new IP address, to change DHCP timeouts or to change the behaviour of the DHCP state machine in any other way.

Note that this has not been observed in some early implementations of IPv4 Link-Local configuration."

Philip

---

From: "Philip Nye" <[email-masked]>
Date: Tue, 16 Dec 2003 23:32:19 -0000

> From: "Ted Lemon" <[email-masked]>
> ...
> This one I don't love:
> 
> I would say instead:
> Several early implementations of IPv4 link-local have modified the DHCP 
> state machine in an attempt to make IPv4 link-local more reliable, and 
> the field experience we have gained from this has shown that it does 
> not work - reliability of DHCP service is significantly reduced.   If 
> increased reliability of IPv4 link-local is desired, we recommend that 
> the IPv4 link-local state machine track the DHCP client state machine 
> and, in cases where it is not certain that the DHCP-assigned address is 
> correct, the IPv4ll state machine acquire an IPv4ll address without 
> causing the DHCP state machine to relinquish its address.

That's fine by me.

Philip