Subject: Re: WG ACTION: 2 weeks to discuss [LL65] Need a requirement for multihomed hosts

From: Stuart Cheshire <[email-masked]>
Date: Thu, 6 May 2004 22:57:27 -0700

My point was this. The document *already* says:

>   If a host has two interfaces on the same network, then claiming and
>   defending on those interfaces must ensure that they end up with
>   different addresses just as if they were on different hosts.

If we say they "must ensure that they end up with different addresses" 
via the usual claiming and defending process, then why not just take the 
next logical step and say they must not try to claim the same address on 
two interfaces in the first place?

Why try something that you know is supposed to fail?

Stuart Cheshire <[email-masked]>
 * Wizard Without Portfolio, Apple Computer, Inc.
 * www.stuartcheshire.org

---

From: "Philip Nye" <[email-masked]>
Date: Fri, 7 May 2004 09:56:28 -0000

> From: "Stuart Cheshire" <[email-masked]>

> two interfaces in the first place?
We only say they must end up with different addresses "If a host has two interfaces on the same network".

We also suggest that the best thing is to run the algorithm independently on each interface and if this is done then the requirement will be met as a consequence of defending one interface against the other and the algorithm need not be explicitly aware of whether they are on a common network or not.

The document talks about the difficulty of trying to run zeroconf on multiple interfaces and in some systems avoiding the same address on multiple interfaces may help reduce the problems - but does not resolve them all. However, in other systems (e.g. where the interface to use is explicitly specified - by some other means than by IP address) then there is not necessarily any problem with using the same address provided those interfaces are on separate networks. Fully independent running of the algorithm may occasionally end up this way without the system ever noticing.

I do not support the proposed change. We should stick to the existing text - maybe change "must" to "MUST"

Philip