Subject: RE: WG ACTION: 2 weeks to discuss [LL61] Remove initial wait

From: "Christian Huitema" <[email-masked]>
Date: Tue, 4 May 2004 16:39:18 -0700

> [LL61]
>  
> Description of Issue:		Remove initial wait
[skip]
> Text becomes:
> 
>     When ready to begin probing, the host should send NUM_PROBES probe
>     packets, spaced randomly, PROBE_MIN to PROBE_MAX seconds apart.

Uh, no. We want to achieve two things: avoid a meltdown in a power
on/off scenario, and space the retransmissions sufficiently to avoid
collisions. However you write it, that means "waiting [0, Probe_max -
Probe_min] for the initial transmission, then NUM_PROBES probe packets,
spaced randomly, PROBE_MIN to PROBE_MAX seconds apart (where Probe_Min
!= 0).

-- Christian Huitema

---

From: Stuart Cheshire <[email-masked]>
Date: Thu, 6 May 2004 22:53:19 -0700

>I believe it should have been random initial delay + retransmissions
>spaced 1 seconds apart, rather than what somehow came out in the
>document.
>
>	MikaL

A long time ago, draft-07 said:

   When ready to begin probing, the host should then wait for a
   random time interval selected uniformly in the range zero to two
   seconds, and should then send four probe packets, spaced two
   seconds apart. This initial random delay helps ensure that a
   large number of hosts powered on at the same time do not all send
   their initial probe packets simultaneously.

With our new parametrized text, this becomes:

   When ready to begin probing, the host should then wait for a random
   time interval selected uniformly in the range zero to START_WAIT
   seconds, and should then send PROBE_NUM probe packets, spaced
   PROBE_INTERVAL seconds apart. This initial randomized delay helps
   ensure that a large number of hosts powered on at the same time do
   not all send their initial probe packets simultaneously.

I believe this is perfectly adequate.

Stuart Cheshire <[email-masked]>
 * Wizard Without Portfolio, Apple Computer, Inc.
 * www.stuartcheshire.org

---

From: "Elder, Alex" <[email-masked]>
Date: Fri, 7 May 2004 07:24:40 -0700

My only comment on this is that the paragraph that would
follow this one in the document should be updated as well,
to indicate something like:

   If during this period, from the beginning of the probing process
   until PROBE_INTERVAL seconds after the last probe packet is sent, the host
   receives any ARP packet

(It previously used "PROBE_MAX" rather than "PROBE_INTERVAL".)

Also, a few paragraphs later:

   If, by PROBE_INTERVAL seconds after the transmission of the last ARP probe
   no conflicting ARP Reply or ARP probe has been received, then the
   host has successfully claimed the desired Link-Local IPv4 address.

(I haven't done any exhaustive review of the document for this
so there could be other spots.)

					-Alex

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Stuart Cheshire
> Sent: Friday, May 07, 2004 12:53 AM
> To: [email-masked]
> Subject: RE: WG ACTION: 2 weeks to discuss [LL61] Remove initial wait
> 
>

---

From: Ralph Droms <[email-masked]>
Date: Tue, 11 May 2004 14:42:58 -0400

I don't think the new text correctly captures either of the behaviors we've 
discussed - I don't see where an initial delay is specified.

I think this text is correct:

    When ready to begin probing, the host should then wait for a random
    time interval selected uniformly in the range 0 to INITIAL_DELAY
    seconds, and should then send NUM_PROBES probe packets, spaced
    randomly, PROBE_MIN to PROBE_MAX seconds apart.

where INITIAL_DELAY is defined somewhere to be 1.

- Ralph

At 01:07 AM 5/5/2004 +0200, Erik Guttman wrote:
>Please post discussion of this issue to the mailing list over the next two 
>weeks
>ending May 18, 2004.  In order to accept this issued, we will need a strong WG
>consensus given that this is very late in the process.
>
>Please see http://www.drizzle.org/~aboba/ZEROCONF/issues.html for a list of
>current issues and their status.
>
>[LL61]
>
>Submitter Name:                 Stuart Cheshire
>Submitter Email Address:        [email-masked]
>Date first submitted:           04 May 04
>Reference:                      LL12
>Comment Type ['t'ech|'e'dit]:   t
>Prio ['S' Must|1 should|2 may]: S
>Section:                        2.2.1
>Rationale/Explanation:
>Lengthy Description:
>
>[Stuart]
>
>>    time interval selected uniformly in the range PROBE_MIN 0
>>    seconds, and should then send NUM_PROBES probe packets, spaced
>>    randomly, PROBE_MIN to PROBE_MAX seconds apart.
>
>Why "wait for a random time interval selected uniformly in the range
>PROBE_MIN to PROBE_MAX"? What's the benefit of enforcing an initial
>one-second delay? It just slows things down.
>
>[Erik]
>
>This delay was intended to stop a set of hosts from beginning at the
>same time in a 'LAN power up' situation.  This text has passed all
>reviews and numerous WG issues to revise and hone it.
>
>[Stuart]
>
>I was not asking about the [0,1] random interval. That's been there since
>draft-05.
>
>I was asking about why it is now 1 + [0,1]. What's the extra fixed
>one-second delay for? What is achieved by making the process uniformly
>take a second longer than it should?
>
>[Erik]
>
>     Hmm.  Reviewing all records, I can't see how this entered the doc.
>     I don't have time for archeology to find out when it entered.  I
>     don't see why waiting an extra second helps, except to wait for
>     network infrastructure to come up (see ll12).
>
>Requested Change:
>
>Text was:
>
>    time interval selected uniformly in the range PROBE_MIN to PROBE_MAX
>    seconds, and should then send NUM_PROBES probe packets, spaced
>    randomly, PROBE_MIN to PROBE_MAX seconds apart.
>
>Text becomes:
>

---

From: "Elder, Alex" <[email-masked]>
Date: Tue, 11 May 2004 12:43:02 -0700

I concur with Ralph's wording.

Caveat:  The second half of it assumes
no change to the random spacing between
probes, which seems less than 100% settled.
Assuming the random delays stand, this wording
is good.

					-Alex

> Behalf Of Ralph Droms
> Sent: Tuesday, May 11, 2004 1:43 PM
> To: [email-masked]
> Subject: Re: WG ACTION: 2 weeks to discuss [LL61] Remove initial wait
> 
> 
> >Please see 
> http://www.drizzle.org/~aboba/ZEROCONF/issues.html for a list of

---

From: Ralph Droms <[email-masked]>
Date: Tue, 11 May 2004 15:54:20 -0400

Alex is correct - the second part of the text depends on the outcome of 
issue LL62, I guess...

- Ralph