Subject: Re: LL70: Use of the term "valid"

From: Bernard Aboba <[email-masked]>
Date: Tue, 18 May 2004 15:34:09 -0700 (PDT)

Jim Busse said:

"Just to clarify my understanding, If the reachability test described in
DNAv4 is skipped, or fails, then IPv4LL can't have a "valid" address,
simply it will have a "routable" address.  In that event, I may assign an
IPv4LL address additionally on that interface, right?"

This might not be a good idea if it's likely that a routable address will
eventually be assigned, since it will cause excessive address changes.
For example in IEEE 802.11, it could be that the reachability test failed
because of packet loss and a subsequent DHCPDISCOVER would succeed.  Is it
helpful to have an IPv4LL address assigned so as to cause existing
connections to go down?  Not necessarily.

In general, the recommended practice is for the host to only assign an
IPV4LL address when it is "likely" that no routable address will be
assigned.  This could occur for example when 802.11 adhoc or Bluetooth PAN
is in use.

---

From: "Philip Nye" <[email-masked]>
Date: Wed, 19 May 2004 10:05:27 +0100

> From: "Bernard Aboba" <[email-masked]>
> Jim Busse said:
> 

Bernard is right - the DNAv4 reachability test is only a rough guide to the appropriateness of an address configuration. It can even give a false positive - e.g. when I have the address 10.x.y.z configured, I can move to another network where the 10/8 range is in use and where the reachability test is passed yet my address is not at all appropriate and may actually conlict.

As humans we can envisage lots of scenarios and because we can generally know something of the state of the whole network, we can usually decide quite clearly whether and when it is appropriate to assign an IPv4LL address.

From inside the host looking out, it is far less easy to know what is going on and come up with an algorithm which does the right thing in all cases. What we are trying to achieve is that implementers will understand the issues and devise algorithms which will do the right thing in the most common cases that they encounter.

The common cases encountered by a PDA with WiFi connectivity are likely to be different from a desktop computer with a wired interface, and different again from a small embedded device such as a scanner with a minimal user interface.

Philip

---

From: Bernard Aboba <[email-masked]>
Date: Wed, 19 May 2004 06:49:23 -0700 (PDT)

> Bernard is right - the DNAv4 reachability test is only a rough guide to the appropriateness
> of an address configuration. It can even give a false positive - e.g.
> when I have the address 10.x.y.z configured, I can move to another
> network where the 10/8 range is in use and where the reachability test
> is passed yet my address is not at all appropriate and may actually conlict.

The reachability test includes determination that the MAC address of the
gateway is unchanged, so I think that case is covered.