Subject: Re: WG ACTION: 2 weeks to discuss [LL52] Text surrounding RFC 2119 clause is poor

From: Stuart Cheshire <[email-masked]>
Date: Thu, 6 May 2004 22:34:44 -0700

>Requested Change:
>
>Omit the unnecessary text before "The key words ..."
>
>Was:
>1.1.  Requirements
>
>    In this document, several words are used to signify the requirements
>    of the specification.  These words are often capitalized.  The key
>    words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT", "SHOULD",
>    "SHOULD NOT", "RECOMMENDED",  "MAY", and "OPTIONAL" in this document
>    are to be interpreted as described in [RFC2119].
>
>Becomes:
>1.1.  Requirements
>
>    The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT", i
>    "SHOULD", "SHOULD NOT", "RECOMMENDED",  "MAY", and "OPTIONAL" in this
>    document are to be interpreted as described in [RFC2119].

Actually, specifically what I'd like is that we just put it back exactly 
how it was in earlier drafts:

   The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT",
   "SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY", and "OPTIONAL" in this
   document are to be interpreted as described in "Key words for use in
   RFCs to Indicate Requirement Levels" [RFC 2119].

Stuart Cheshire <[email-masked]>
 * Wizard Without Portfolio, Apple Computer, Inc.
 * www.stuartcheshire.org

---

From: Ralph Droms <[email-masked]>
Date: Fri, 07 May 2004 05:52:45 -0400

As I suggested earlier, we should follow the recommendation of RFC 2119:

    Authors who follow these guidelines
    should incorporate this phrase near the beginning of their document:

       The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL
       NOT", "SHOULD", "SHOULD NOT", "RECOMMENDED",  "MAY", and
       "OPTIONAL" in this document are to be interpreted as described in
       RFC 2119.

- Ralph

---

From: "Philip Nye" <[email-masked]>
Date: Fri, 7 May 2004 10:40:03 -0000

> From: "Ralph Droms" <[email-masked]>
>

We have the recommended text verbatim from RFC2119.

We also have two introductory sentences: "In this document, several words are used to signify the requirements of the specification. These words are often capitalized."

The two extra sentences are also lifted directly from RFC2119 and as such it is hard to argue against them. They may be redundant, but they are not harmful and it should be too late to change them.

Philip