Subject: Re: WG ACTION: 2 weeks to discuss [LL55] 'Prevent' is too strong

From: Stuart Cheshire <[email-masked]>
Date: Thu, 6 May 2004 22:47:02 -0700

>  | The IP address of my printer is 169.254.207.63.
>  | 
>  | There, I just used a Link-Local address in off-link communication.
>
>No, you didn't use the address, you just typed it, the address
>wasn't used (not as an address anyway).

Robert, please re-read the section in question.

It is not talking about addresses used "as addresses", it is talking 
about a prohibition on addresses appearing as data within the IP payload 
of other packets that DO go off-link, such as DNS packets.

The word "use" in this context means "place it in a packet that goes 
off-link".

Stuart Cheshire <[email-masked]>
 * Wizard Without Portfolio, Apple Computer, Inc.
 * www.stuartcheshire.org

---

From: Robert Elz <[email-masked]>
Date: Sat, 08 May 2004 02:13:05 +0700

Date:        Thu, 6 May 2004 22:47:02 -0700
    From:        Stuart Cheshire <[email-masked]>
    Message-ID:  <[email-masked]>

  | The word "use" in this context means "place it in a packet that goes 
  | off-link".

Yes, but it has to be there as an address, in a context where using
it as an address would make sense.   Beyond that the restriction would
be absurd - it would prohibit particular bit patterns in jpeg files
(or compressed data) for example...

Anyone reading this who can't work that out for themselves is beyond hope.

kre