Subject: WG ACTION: 2 weeks to discuss [LL54] Consistent terminology for out of scope

From: Erik Guttman <[email-masked]>
Date: Wed, 5 May 2004 01:00:29 +0200

Please post discussion of this issue to the mailing list over the 
next two weeks
ending May 18, 2004.  In order to accept this issued, we will need a strong WG
consensus given that this is very late in the process.

Please see http://www.drizzle.org/~aboba/ZEROCONF/issues.html for a list of
current issues and their status.

[LL54]

Description of Issue:		Consistent terminology for out of scope
Submitter Name:		Stuart Cheshire
Submitter Email Address:	[email-masked]
Date first submitted:		04 May 04
Reference:
Comment Type ['t'ech|'e'dit]:	e
Prio ['S' Must|1 should|2 may]:	1
Section:			1.3, 2.2.1
Rationale/Explanation:
Lengthy Description:

Page 5 says:

>    Link-layer technologies that do not support ARP may be able to use
>    other techniques for determining whether a particular IP address is
>    currently in use. However, the application of claim-and-defend
>    mechanisms to such networks is outside the scope of this document.

Page 10/11 say:

>    On a link-layer such as IEEE 802 that supports ARP, conflict
>    detection is done using ARP probes. On link-layer technologies that
>    do not support ARP other techniques may be available for determining
>    whether a particular IPv4 address is currently in use.  However, the
>    application of claim-and-defend mechanisms to such networks is left
>    to a future document.

Lets be consistent. Can we pick one phrase? Either "outside the scope of
this document" or "left to a future document".

Requested Change:

Use consistent terminology: 'out of scope' in each case.

---

From: Ralph Droms <[email-masked]>
Date: Tue, 04 May 2004 20:54:04 -0400

I agree with the proposed change.

- Ralph

At 01:00 AM 5/5/2004 +0200, Erik Guttman wrote:
>Please post discussion of this issue to the mailing list over the next two 
>weeks

---

From: Robert Elz <[email-masked]>
Date: Wed, 05 May 2004 07:56:23 +0700

Date:        Wed, 5 May 2004 01:00:29 +0200
    From:        Erik Guttman <[email-masked]>
    Message-ID:  <a05200f19bcbdce82ea64@[80.139.178.51]>

  | Lets be consistent. Can we pick one phrase? Either "outside the scope of
  | this document" or "left to a future document".

This isn't even worth discussing, the text as it stands is fine.
(It would be OK if it had used the same phrase both places, but there's
no need to go changing it now just for that purpose).

kre

---

From: "Philip Nye" <[email-masked]>
Date: Fri, 7 May 2004 11:05:57 -0000

> this document" or "left to a future document".

I really don't care which phrase we use, nor do I mind using both in different places, but it is way too late to make trivial changes like this.

Philip

---

From: "John C. Welch" <[email-masked]>
Date: Fri, 07 May 2004 09:02:20 -0500

> Use consistent terminology: 'out of scope' in each case.

Agreed. "Out of scope" implies that however this is settled, it won't be
here. "In a future document" implies that it may be settled in a future rev
of this document, in a future rev of some other document, some document that
is being built, or in some document that does not yet exist, and may never
exist.

"Out of scope" is simpler, and more clear.

john

-- 
Paene meracus malorum sum
(I am nearly pure evil)