Subject: Re: WG ACTION: 2 weeks to discuss [LL63] Text could be more specific

From: Stuart Cheshire <[email-masked]>
Date: Fri, 7 May 2004 10:52:22 -0700

>   Field experience has shown that modifying the DHCP state machine
>   in an attempt to make IPv4 Link-Local more reliable does not work
>   - reliability of DHCP service is significantly reduced.

I have no objection to giving our best known advice:

>    A device that implements both IPv4 Link-Local and a DHCPv4 client
>    should not alter  the behavior of the DHCPv4 client to accommodate

My objection is to inventing fictitious "early implementations" or "field 
experience" to apparently back up our advice.

This is strangely topical -- the US president and the US and UK 
governments are taking a lot of criticism right now for the alleged 
fabrication of supporting evidence to justify their chosen course of 
action.

What is this claimed "field experience"? Is it a pure fiction?

Stuart Cheshire <[email-masked]>
 * Wizard Without Portfolio, Apple Computer, Inc.
 * www.stuartcheshire.org

---

From: "Philip Nye" <[email-masked]>
Date: Fri, 7 May 2004 21:50:03 -0000

> From: "Stuart Cheshire" <[email-masked]>
>

I had taken it on good faith in the original authors that it was the case that this was based on experience - it has been there since before I joined in. My experience with some Windows implementations certainly suggests that the IPv4LL and DHCP are entangled but this is purely anecdotal and could be caused by other things - I have no access to the Windows code to confirm this or otherwise and would not want to. If you are correct that it is fiction then I agree that this assertion could be removed. However, why wasn't it weeded out at draft 2 or 3?

> fabrication of supporting evidence to justify their chosen course of 

So Stuart which side are you on? - are you with Dubya or are you with the terrorists? (no you shouldn't answer!)

Philip