Subject: RE: WG ACTION: 2 weeks to discuss [LL68] Stress constants are not user configurable

From: "Elder, Alex" <[email-masked]>
Date: Tue, 4 May 2004 21:41:48 -0700

I have no objection to making it clear that
the symbolic values do not imply they are
configurable.

But behind that I don't agree with the statmeent
that a symbol implies an abstraction which implies
configurability.  The benefit of using a symbolic
value is that it can improve clarity, providing
more meaning than (for example) a raw number can.

But I'm sure Stuart isn't the only one that will
interpret this use that way, so I see no problem
with some clarification.

					-Alex

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of Erik Guttman
> Sent: Tuesday, May 04, 2004 6:23 PM
> To: [email-masked]
> Subject: WG ACTION: 2 weeks to discuss [LL68] Stress constants are not
> user configurable
> 
> 
> Please post discussion of this issue to the mailing list over the 
> next two weeks
> ending May 18, 2004.  In order to accept this issued, we will 
> need a strong WG
> consensus given that this is very late in the process.
> 
> Please see http://www.drizzle.org/~aboba/ZEROCONF/issues.html 
> for a list of
> current issues and their status.
> 
> [ll68]
> 
> Description of Issue:		Stress constants are not user 
> configurable
> Submitter Name:                 Stuart Cheshire
> Submitter Email Address:        [email-masked]
> Date first submitted:           04 May 04
> Reference:
> Comment Type ['t'ech|'e'dit]:	e
> Prio ['S' Must|1 should|2 may]:	s
> Section:			all
> Rationale/Explanation:
> Lengthy Description:
> 
> [Stuart]
> 
> Also, we need to stress that these are MUST NOT be user-configurable
> options, or the users will just decide they can set them to 
> zero to "make
> it go faster".
> 
> [Erik]
> 
> No user configurable options are mentioned in the text.  I do not
> understand what you mean by 'set them to zero.'  What settings are you
> referring to?
> 
> [Stuart]
> 
> When you use symbolic identifiers in place of concrete values 
> it implies
> abstraction (Generalisation; ignoring or hiding details to 
> capture some
> kind of commonality between different instances), which 
> implies therefore
> that there are different instances with different values for those
> abstracted identifiers.
> 
> If the intention is that different instances will have 
> different values
> for these symbolic identifiers, then the draft should say so.
> 
> If the intention is that different instances will have NOT different
> values for these symbolic identifiers, then the draft should say so.
> 
> I'm just asking for clarification.
> 
> [Erik]
> 
> The reasons we are using constants are
>      * The WG called for it, primarily
>      * There has been an interest in specifying new sets of
>        constants 'in the future' for specific link layers which
>        might call for different timing
>      * Use of constants instead of values in the text is considered
>        absolutely necessary by many technical reviewers, for clarity
>        and style consistent with other IETF published technical
>        documentation.
>      * Use of a constant term assures the assignment of the term will
>        be in one authoritative place.  This improves the overall
>        consistency of the document and improves ease of reference.
>        In this respect technical writing parallels acceptable program
>        coding practice.
> 
> Requested Change:
> 
> TEXT NEEDED
>

---

From: Stuart Cheshire <[email-masked]>
Date: Thu, 6 May 2004 23:00:12 -0700

>TEXT NEEDED

Hopefully my proposed changes for LL53 address this.

Stuart Cheshire <[email-masked]>
 * Wizard Without Portfolio, Apple Computer, Inc.
 * www.stuartcheshire.org

---

From: Stuart Cheshire <[email-masked]>
Date: Fri, 7 May 2004 10:53:09 -0700

>this is a protocol specification, not a guide for dummies.

This argument -- "this would make the document clearer and easier to 
understand, therefore it is a bad thing" -- is not one that convinces me.